How to Fix: configure: error: Package requirements (neon >= 0.27) were not met:

So you got this, huh:

checking for NEON... no
configure: error: Package requirements (neon >= 0.27) were not met:

No package 'neon' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables NEON_CFLAGS
and NEON_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To fix it, type the following in your Terminal:

sudo apt-get install libneon27-gnutls-dev

How to Fix: configure: error: FFmpeg is not installed or too old

So you got this, huh:

checking for FFMPEG... no
configure: error: FFmpeg is not installed or too old (required: libavcodec 53.40.0, libavformat 53.21.0, libavutil 51.27.0).  Use --with-ffmpeg=none to disable the ffaudio plugin or --with-ffmpeg=libav to use libav instead.

To fix it, type the following in your Terminal:

sudo apt-get install libavcodec-dev libavformat-dev libavutil-dev

How to Fix: configure: error: Package requirements (flac >= 1.2.1) were not met:

So you got this, huh:

checking for LIBFLAC... no
configure: error: Package requirements (flac >= 1.2.1) were not met:

No package 'flac' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBFLAC_CFLAGS
and LIBFLAC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To fix it, type the following in your Terminal:

sudo apt-get install libflac-dev

How to Fix: configure: error: Package requirements (ogg >= 1.0 vorbis >= 1.0 vorbisenc >= 1.0 vorbisfile >= 1.0) were not met:

So you got this, huh:

configure: error: Package requirements (ogg >= 1.0 vorbis >= 1.0 vorbisenc >= 1.0 vorbisfile >= 1.0) were not met:

No package 'ogg' found
No package 'vorbis' found
No package 'vorbisenc' found
No package 'vorbisfile' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables VORBIS_CFLAGS
and VORBIS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To fix it, type the following in your Terminal:

sudo apt-get install libogg-dev libvorbis-dev

How to Fix: configure: error: Package requirements (libxml-2.0) were not met:

So you got this, huh:

checking for XML... no
configure: error: Package requirements (libxml-2.0) were not met:

No package 'libxml-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XML_CFLAGS
and XML_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To fix it, type the following in your Terminal:

sudo apt-get install libxml2-dev 

How to Fix: configure: error: Package requirements (glib-2.0 >= 2.32) were not met:

So you got this, huh:

checking for GLIB... no
configure: error: Package requirements (glib-2.0 >= 2.32) were not met:

No package 'glib-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

To fix it, type the following in your Terminal:

sudo sudo  apt-get install libgtk2.0-dev

How to Fix: configure: error: We could not detect the boost libraries

So you got this, huh:

checking for boostlib >= 1.33.1... configure: error: We could not detect the boost libraries (version 1.33 or higher). If you have a staged boost library (still not installed) please specify $BOOST_ROOT in your environment and do not give a PATH to --with-boost option.  If you are sure you have boost installed, then check your version number looking in . See http://randspringer.de/boost for more documentation.

To fix it, type the following in your Terminal:

sudo apt-get install libboost-dev