How to Fix: configure: error: Package requirements (libcanberra >= 0.1 libcanberra-gtk3 >= 0.1) were not met:

So you got this, huh:

configure: error: Package requirements (libcanberra >= 0.1
	      libcanberra-gtk3 >= 0.1) were not met:

No package 'libcanberra' found
No package 'libcanberra-gtk3' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

To fix it, type the following in your Terminal:

sudo apt-get install libcanberra-dev libcanberra-gtk-common-dev libcanberra-gtk3-dev

How to Fix: configure: error: Package requirements (gtk+-3.0 >= 3.0.0 gdk-x11-3.0) were not met:

So you got this, huh:

configure: error: Package requirements (		  gtk+-3.0 >= 3.0.0	  gdk-x11-3.0) were not met:

No package 'gtk+-3.0' found
No package 'gdk-x11-3.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.	

To fix it, type the following in your Terminal:

sudo apt-get install libgtk-3-dev libgdk-pixbuf2.0-dev

How to Fix: configure: error: Package requirements (gstreamer-1.0 >= 0.11.92 gstreamer-base-1.0 >= 0.11.92 gstreamer-video-1.0 >= 0.11.92 gstreamer-pbutils-1.0 >= 0.11.92 gstreamer-tag-1.0 >= 0.11.92) were not met:

So you got this, huh:

configure: error: Package requirements (	gstreamer-1.0 >= 0.11.92	gstreamer-base-1.0 >= 0.11.92			gstreamer-video-1.0 >= 0.11.92	gstreamer-pbutils-1.0 >= 0.11.92 	gstreamer-tag-1.0 >= 0.11.92) were not met:

No package 'gstreamer-1.0' found
No package 'gstreamer-base-1.0' found
No package 'gstreamer-video-1.0' found
No package 'gstreamer-pbutils-1.0' found
No package 'gstreamer-tag-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

To fix it, type the following in your Terminal:

sudo apt-get install libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev